Citra freezes on launch, log file empty

When launching Citra (either Nightly or Canary), the start screen appears, it asks about telemetry data, but whichever option I choose,it’s nonresponsive after that for 15+ minutes, the task reports “Not responding”. The log file is empty so there’s nothing to start out on. Tried fully uninstalling and reinstalling and also the portable version, to no avail.

System Information (note: it’s a laptop)

  • Operating System: Windows 11 64-bit 22H2
  • CPU: AMD Ryzen 7 5800H
  • GPU: Geforce RTX 3070
  • Citra Version (found in title bar): tried Nightly 1993 and Canary 2623
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar):

(“Nem válaszol” is “Not responding”, my system language is hungarian)

Diagnostic Log
N/A, citra_log.txt is empty and 0KB in size

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File