Citra freezes to 0 FPS after 1 minute playing

Issue:
I was playing Ocarina of Time 3D on Citra emulator and after just 2 minutes of gaming Citra just freeze to 0 FPS out of nowhere.

I tried many times to save Slots from minute to minute to get through the initial cinematic, but unfortunately the freezing continues, each time in a different place, but i can’t even play the first 2 minutes without freezing.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7-4510U - CPU 2.0GHz 2.60 GHz
  • GPU: NVIDIA GeForce GT 740M
  • Citra Version: 1795
  • Game: Ocarina of Time 3D
  • Screenshot of Issue: http://prntscr.com/t86tdk

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
citra_log.txt (74.3 KB)

System Information for Support

Client Version                                Canary 1795 HEAD-61f0e52
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GT 740M/PCIe/SSE2
GPU Driver Version                            369.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Update your drivers: https://www.nvidia.com/Download/driverResults.aspx/145874/en-us

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Accurate Multiplication is also required to not get invisible icons in this game.

I tried this and Citra keeps freezing, follow below the image file and Log_File.

citra_log.txt (100.9 KB)

System Information for Support

Client Version                                Canary 1797 HEAD-697ea32
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GT 740M/PCIe/SSE2
GPU Driver Version                            425.31
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I think I know what is happening:
I entered the button Advance Frame, and then my game freezes and olny goes from frame to frame.

So I’ll disable this shortcut and keep testing again.

Thanks for your help.

1 Like