Citra Freezes Up

Issue:
I just updated to the latest build of Windows, specifically Build No. 1909 which is the latest version of Windows, released in May and a previous problem I had has returned. Previously, my system’s drivers weren’t up to date so Citra freezed. Now, this issue has returned once more but my drivers seem to be up to date. I updated the drivers for the Computer section in Device Manager if that’s what you were wondering about. What can I do?

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel i5 3340M
  • GPU: None
  • Citra Version (found in title bar): Canary 1773
  • Game: All
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (25.3 KB)

System Information for Support

Client Version                                Canary 1773 HEAD-d299355
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4425
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Oh so drivers were the problem

Nope, Still freezing

citra_log.txt (25.3 KB)

System Information for Support

Client Version                                Canary 1773 HEAD-d299355
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4425
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

what the crud!!!

GPU Driver Version: Build 10.18.10.4425

This driver is outdated, you need to update.

Download win64_15.33.50.5129.zip from https://downloadcenter.intel.com/download/29473/Intel-Graphics-Driver-for-Windows-15-33-?product=71257
direct link: https://downloadmirror.intel.com/29473/a08/win64_15.33.50.5129.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Since you have an old GPU which can randomly crash due to a driver bug you might need to use Nightly 1392 until you upgrade your computer as it is the last build before the Split Presentation Thread change: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

No the thing is when I had this problem before with the split presentation thread and stuff, updating drivers fixed it. I think this new driver update will fix this too. Thanks again, I tried manually installing the zip file from the bot’s suggested website but it failed. You’re a great help! I’ll see if the driver update works

1 Like

The disk shader fix didn’t work, seems to be the driver update

If for some reason the driver reverts itself to an older version, see:

The shader cache fix is to prevent a different issue that will show up eventually if you don’t do the steps

Yup, the driver update fixed it. Thanks tywald!

1 Like