Citra having fluctuating performance

Issue:
Enter a description of your issue here, in full detail
Citra will run really well on one day and then run really slow on another. I usually paly at 300 percent speed or something, but some days it can barely go up to 110.

System Information

  • Operating System: Windows 10
  • CPU: i7 1065G7
  • GPU: Intel Iris Plus Graphics
  • Citra Version (found in title bar): Citra Canary 1856
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (75.4 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1856 HEAD-ee9df14
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-1065G7 CPU @ 1.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) Iris(R) Plus Graphics
GPU Driver Version                            26.20.100.7870
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: 26.20.100.7870

This driver is outdated, you need to update.

Download and install igfx_win10_100.8783.exe from: https://downloadcenter.intel.com/download/29904/Intel-Graphics-Windows-10-DCH-Drivers?product=196597
direct link: https://downloadmirror.intel.com/29904/a08/igfx_win10_100.8783.exe

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Make sure you are using a high performance power plan in Windows.

when i turn on accurate multiplication it slows down drastically

Then you’d have to deactivate Disk Shader Cache. Without Accurate Multiplication, the Disk Shader Cache will cause crashing later on. So you can’t leave it on.

ive been playing for a long time tho and it never crashed yet

The speed at which the cache starts causing problems due to the bug is different depending on what hardware you’re using. However, the fact that it will cause problems doesn’t change.
Tywald already explained the bug to you. If you choose not to believe it, it’s up to you

i just realized that if i charge the laptop, then the speed and fps will skyrocket, but when its not charging, it will remain incredibly low. Anyone have a fix for this?

Check the last part of tywald’s message:

I am using a high performance power plan i think. How do u check again?

Haven’t used a laptop in a while so this might’ve been changed: Right click on your battery icon on your taskbar, then select power options. I think it should be there

it still only gets up to 140 percent speed when i put everything on maximum performance

Please upload another log file

citra_log.txt (58.3 KB)

System Information for Support

Client Version                                Canary 1856 HEAD-ee9df14
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-1065G7 CPU @ 1.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) Iris(R) Plus Graphics
GPU Driver Version                            27.20.100.8783
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Remember that when you run on battery it won’t have the exact same performance like when you are plugged in.

yea ok thanks for the help at least!

1 Like