Citra immediately crashes upon loading Mii Maker

Issue:
I’ve tried opening my “mii maker.app” file in citra, but as soon as i do, it crashed the emulator.
It happens on any version, it seems like. I tried the most recent version (as of 9/11/17), a version from 5 days ago, and a month ago.

System Information

  • Operating System: Ubuntu 16.04
  • CPU: ?
  • GPU: ?
  • Citra Version (found in title bar): HEAD-4af793c
  • Game: Mii Maker
  • Screenshot of Issue (include the full Citra window including titlebar):

I don’t know what my CPU/GPU are exactly, but when I get a game to run, it runs at a good, playable framerate (35-40 fps), and I have 8 GB ram and a four-core processor.

Log:

./citra mii%20maker.app
[ 0.000000] Config citra/config.cpp:LoadINI:40: Successfully loaded /home/mpg13/.config/citra-emu/sdl2-config.ini
[ 0.011178] Audio audio_core/sink_details.cpp:GetSinkDetails:32: AudioCore::SelectSink given invalid sink_id
[ 0.333638] Loader core/loader/loader.cpp:GetLoader:126: Failed to load file mii%20maker.app
[ 0.333785] Core core/core.cpp:Load:75: Failed to obtain loader for mii%20maker.app!
[ 0.333799] Frontend citra/citra.cpp:main:141: Failed to obtain loader for mii%20maker.app!
Segmentation fault (core dumped)

.app isn’t a 3ds file format that any tool i know of dumps to. redump mii maker from your 3ds with godmode9 following the guide in the wiki

citra shouldn’t crash there tho… thats weird to say the least. but the problem is theres no .app file loader so it can’t launch your game of course.

Make sure that the name of the ROM is correct, I’m not sure if the space is being encoded by the forum or something, or if you’re actually entering the %20. Do you have any reason to specifically use the SDL2 frontend (citra)? The Qt frontend (citra-qt) allows you to just select the ROM from a file browser.

Make sure the APP is decrypted. You can make sure it is by, from GodMode9 on your 3DS, pressing (A) on it, going into the NCCH options, and selecting decrypt.

APP is what the system titles in the CTRNAND are named, they’re just NCCH containers. I was able to run the Internet Browser APP dumped from my 3DS.