Citra is crushing when trying to use shovel in Animal Crossing: New Leaf - Welcome Amiibo

My “Animal Crossing: New Leaf - Welcome Amiibo” became very glitchy some time ago, tho it worked perfectly before. I think I fixed emulation speed drop by updating my drivers and resetting Citra, but it still crashes when I’m trying to use a shovel. Sometimes I can dig up something without problems, but more often the game just freezes and crashes along with Citra.
Update: so I have updated Citra to the latest version this morning and things got even worse. Now emulation speed drops up to ~50% even when I’m inside the house/shop and it dropped only when I was outside before. Problem with a shovel is still the same. Also I replaced the log file just in case.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-8250U
  • GPU: Intel UHD Graphics 620
  • Citra Version: 1979
  • Game: Animal Crossing: New Leaf - Welcome Amiibo

Diagnostic Log
citra_log.txt.old.txt (123.8 KB)

System Information for Support

Client Version                               Nightly 1979  HEAD-df57012
Operating System                             Windows 10 Version 22H2 (Build 19045.3324)
CPU                                          Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce MX150/PCIe/SSE2
GPU Driver Version                           537.13
CPU JIT                                      [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

Go to Emulation>Configure>Graphics>Advanced Tab and re-enable Hardware Shaders.

Thank you very much, it helped!