Citra is extremely slow while playing Super Mario 3D Land and Mario Kart 7 and i don't know why

Issue:
So i was trying to play Super Mario 3d Land and Mario Kart 7 on pc with the Citra Nightly 1696 but its super slow, games running at 50% to 70% speed in those games, and i know that my pc can run these games, i run emulators like Cemu, Dolphin, PPSSPP and in some games yuzu at full speed, and Citra is so much slower and I’m running at native resolution, its basically unplayable, can someone help me fix this problem?

System Information

  • Operating System: Windows 10 Home And Pop Os! (Ubuntu based Linux distro)
  • CPU: I7-8550U 1.80GHz
  • GPU: MX 130 and Intel UHD 620 (i switched in the Nvidia control panel to use the mx130 on Citra)
  • Citra Version (found in title bar): Nightly 1696
  • Game: Super Mario 3D Land and Mario Kart 7
  • Screenshot of Issue (include the full Citra window including titlebar):

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (129.5 KB)

System Information for Support

Client Version                                Nightly 1696 HEAD-8e3c767
Operating System                              Windows 7 (6.1)
CPU                                           Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce MX130/PCIe/SSE2
GPU Driver Version                            461.40
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

I Switched the CPU Clock to 100% and it still is slow better but still slow.
citra_log.txt (154.6 KB)

System Information for Support

Client Version                                Nightly 1696 HEAD-8e3c767
Operating System                              Windows 7 (6.1)
CPU                                           Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce MX130/PCIe/SSE2
GPU Driver Version                            461.40
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

I FIXED IT WHAT!

citra_log.txt (17.0 KB)

System Information for Support

Client Version                                Nightly 1696 HEAD-8e3c767
Operating System                              Windows 7 (6.1)
CPU                                           Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce MX130/PCIe/SSE2
GPU Driver Version                            461.40
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This seems a bit odd. Can you confirm that you didn’t get that bit of information wrong?

Yeah I thought it was wierd too, but I’m using windows 10 Home!

Have you checked your PC’s power mode?

Yes its in Maximum performance both in windows power mode and linux’s and in the nvidia control panel its set to maximum performance and performance over quality.