Citra is running slow

Issues
In these last days i always used emulator to play (VBA too) but randomly the emulator started to slow down, citra inclueded. I didn’t know why, last time i used it was super fast and i was playing Ultramoon (which goes sharply and fast). Pokemon X is so laggy, especially in parts where are conversation or change of route. The strange it’s that when i’m free to run in the route, it’s so fast. It never happened to me. What’s wrong? Is it my fault? I touched something?
Can anyone help me? This is the log. Sorry for my bad english. Thanks again

System Information

  • Operating System: Windows 10 (or Kubuntu)
  • CPU: i5-5200U @220 GHZ, 2 core, 4 processor
  • GPU: AMD Radeon M330
  • Citra Version (found in title bar): Nightly 1589
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (50.8 KB)

System Information for Support

Client Version                                Nightly 1589 HEAD-96fa75f
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) R5 M330
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Citra was running perfectly when this happened (and other emulators too) and enabling accurate moltiplication didn’t solve the things.

First, make sure you have the latest drivers. Download and install Adrenalin 2020 Edition 20.7.1 from https://www.amd.com/en/support/graphics/amd-radeon-r5-series/amd-radeon-r5-300-series/amd-radeon-r5-m330

Select Factory Reset in the installer to make sure you get a clean installation.

I just downloaded the last version of AMD software and i have discovered that i have two GPU: display i have Intel Graphics (HD) 5500 while for rendering i have the AMD Radeon. Now citra is running faster but it’s laggy in some points. Can I do something else? Btw, thanks for your help, you are very kind and helpful. Thanks a lot.

Intel HD 5500 has driver bugs unfortunately so it is not recommended to use it.

Since you have Radeon, you can try dual boot Linux (e.g Ubuntu) to get more performance, up to like 3x more in some cases.

1 Like

I had this same issue, are you playing on a laptop? I am and weirdly I found that it would slow down when I changed the power source and would not resolve itself, I tried everything.
Strangly enough what fixed it for me was I closed citra and then pulled the plug from the back of my laptop, plugged it back in opened it up and bingo its worked fine since. Can’t really explain it though :sweat_smile:

so my pc is stupid and slow! is i have a6-7480 3.50 GHz is bad my citra don’t working :frowning:

citra_log.txt (28.2 KB)

System Information for Support

Client Version                               Nightly 1768   HEAD-b7c1c21
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Pentium(R) Silver N6000 @ 1.10GHz
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics Gen11
GPU Driver Version                           30.0.101.1692
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.