Citra is running very slow

Citra is running very slow.

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log

System Information for Support

Client Version                                Nightly 1695 HEAD-c2d36cd
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) 520
GPU Driver Version                            21.19.412.1280
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

You’ve edited out your log file from your post. We can’t help you if we don’t have a workable log file.

Mine is running very slow too…

citra_log.txt (23.3 KB)

GL_VERSION: 4.3.0 - Build
^ This driver is out of date. To update, download and install gfx_win_101.4255.exe from Intel® Arc™ & Iris® Xe Graphics - WHQL - Windows*
Mirror download:

Hi SleepingSnake and support team!

Still… after driver update, Citra is still using OpenGL 4.3… is it possible to force 4.6 or 4.5 version?
[ 3.976227] Render.OpenGL video_core/renderer_opengl/gl_driver.cpp:ReportDriverInfo:99: GL_VERSION: 4.3.0 - Build
[ 3.976286] Render.OpenGL video_core/renderer_opengl/gl_driver.cpp:ReportDriverInfo:100: GL_VENDOR: Intel
[ 3.976327] Render.OpenGL video_core/renderer_opengl/gl_driver.cpp:ReportDriverInfo:101: GL_RENDERER: Intel(R) UHD Graphics

Last log… maybe no relevant differences…
citra_log.txt (22.8 KB)

That’s not how any of this works. Citra targets OpenGL 4.3, since that’s the OpenGL version which’s extensions have everything we need. Newer OpenGL versions, like 4.6 only carry more “options” that can be implemented. In short, it includes more stuff you could use, but it doesn’t improve upon old stuff.

Think of it like a toolkit. Where OpenGL 4.3 has wrenches and screwdrivers, OpenGL 4.6 has wrenches screwdrivers and a hammer. Just because we force Citra to use OpenGL 4.6, doesn’t mean that suddenly the wrenches and screwdrivers have changed in any way. So, since Citra only needs the “tools” in OpenGL 4.3, there’s no reason to force OpenGL 4.6.

Could you give us an example on the performance you’re getting? What’s the emulation speed like?

screen capture 2023-03-31 231008

speed = velocidade = rounding between 45 to 100%
game = jogo = between 25 to 60 fps

of course… only native resolution… no way I can 2x the resolution…

Hmmm, start up Citra again, but keep the window small (so that you can freely drag it around your screen). Start your game, and when you encounter the performance issue, start dragging your Citra window around (slow enough that you can keep track of the performance counter). Let me know if that increases the performance for you.

tried it… I noted slightly a better performance … it looks like speed increases from 50 to 60~70%… wow, that’s really weird.

edit: I’m trying New Super Mario 2

Hmmm, right click on your Windows start button and select Device Manager. Expand the Display Adapters tab and tell me what it says there.

Nothing strange here… just the Intel UHD Graphics as expected (at least I think).


I’m trying to append the image but it is not uploading…
but anyway, there is only one adapter (Intel UHD Graphics)

Yea, the server appears to be having issues with uploading images. I’ve already contacted the maintainer about this. Hopefully we can get that fixed :sweat:

This may be part of some sort of regression on Citra’s end (we’ve had some other users report similar behavior). But first, make sure that your laptop is plugged into power whilst using Citra. Laptops often decrease the CPU usage when on battery to preserve battery life, so that can significantly decrease performance.

Thanks for your help!
I have a minipc… so, power is always on.
I changed the energy mode to “high performance” in my Windows… now, game (on citra) is playing much better with acceptable speed.

I will look forward for citra development.