Citra is very slow and has low CPU/GPU usage

Issue:
Citra is very slow (~20-35 FPS) in Mario Kart 7 and Super Mario 3D Land while only using ~25% CPU and ~35% GPU even on lowest settings. Screenshot
Is there any setting limiting the usage? Because Dolphin and CEMU run at 1080p 60FPS without any stutter at all.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4570 - 4x3.20GHz
  • GPU: PowerColor AMD Radeon R9 280
  • Citra Version (found in title bar): Citra Nightly 1035
  • Game: Mario Kart 7 and Super Mario 3D Land
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (28.9 KB)

I found some issues in that log that need resolving:

while only using ~25% CPU

Citra uses only a single core, however the latest canary build does have Threaded CPU vertex shader processing which uses more cores (the max i saw was 3 cores) when ‘Enable Hardware Shader’ is disable, however that may not help you much. if you want to try, i believe this has been only implemented on the latest canary.

~35% GPU even on lowest settings

citra isn’t very GPU demanding, and it should use more on highest settings…

btw citra doesn’t perform very well on amd gpus (you may know that already, amd opengl drivers).

mario kart 7 is demanding, but SM3DL should perform well enough on your cpu, if you don’t have other demanding apps open, and if you don’t have cpu heating/throttling issues.

edit: btw, disable v-sync.

1 Like

Thanks such much for your answer!
Disabling V-Sync fixed it and I can play with 60FPS now :smiley: