Citra is working much slower on my New computer

#1

Issue:
Guys i recently bought the new Aero 15x 8th laptop from gigabyte. the computer is a beast and for the life of me i dont understand why citr is working so slow for me. and the most frustrating thing that at my old computer, which is allmost 10 years old i can run citra smoothly without any problems…

while i was viewing videos about it i saw that a lot of them recommending to go to the configurations general section and in performance crossing off the enable CPU JIT option and then i notice it doesnt appear on my citra… maybe i need to download a different version of the emulator? i saw that there were GPU builds but didnt understand where to download them. anyway i think an i7 8750k cpu with 32gb ram is more than enough to handle citra even without the gpu so i’d really like to know what is the problem

System Information

  • Operating System: windows 10
  • CPU: GTX 1070 Max q version
  • GPU: i7 8750k 32 GB Ram
  • Citra Version (found in title bar): latest canary and nightly build
  • Game: all games
#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

CPU JIT should be enable as it probably works with any game currently (besides giving a massive performance boost). on the latest canary this option is under Emulation > Configure > Debug.

#4

YES i switched off the cpu jit and now the games works incredibly fast, thanks!

i still dont really understand why the games work faster with the cpu jit off tought

edit:
after i switched it off i’m getting around 200% speed average and 60 fps average, i still think my computer can push more than that, i currently use a 144 hz monitor is there a way to push it to 140fps?

#5

why the games work faster with the cpu jit

Which games? i don’t see how that could be possible unless its a weird edge case.

i currently use a 144 hz monitor is there a way to push it to 140fps

You can unlock your framerate with CTRL+Z. your Refresh rate isn’t a limitation to how many frames your pc can push.

#6

Hey guys sorry i now see that the reason for the preformance drop wasnt the CPU JIT. the computer was programmed to have limited preformacne while it unplugged, so when i plugged it and tried to play citra run normally.

my secound question is that if i can run the game on 100% and still have 144 fps?, i see that when i limit the speed my fps are locked on 60. and when i press Ctrl + Z the fps jumps

#7

Most 3DS games are either 30/60 fps capped or 30/60 uncapped (there are exceptions, but never above 60 AFAIK) pushing framelimit above 100% will speed up emulation. when citra becomes more ‘full-featured’, there will be something like pcsx2 or dolphin enhancements, even then i don’t know many game enhancements for most emulators that just unlocks framerate, i wouldn’t expect such enhancements.

1 Like
#8

alright i understand, thanks for the fast responses and the support, you can close this thread now