Citra isn't working in my GT840M

#1

Issue:

Hello guys. I’m very sad to ask for help. I tried using citra on my laptop but it is not working. I think my video card is very weak, I have a Geforce 840M, and it is not capable of running the program and games. I do not believe that such a board is not capable of running the system of a 3DS, which the nintendo console would have so powerful that it can not run on my pc. Unless I’m doing something very wrong.

System Information

  • Operating System: Windows 8.1
  • CPU: Intel Core i7-4510U CPU 2.00 GHz
  • GPU: GeForce 840M
  • Citra Version (found in title bar): Citra Nightly 1224
  • Game: Pokemon Sun e Moon

Print Screen

Log
citra_log.txt (35.1 KB)

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

System Information for Support

Client Version                                Nightly 1224 HEAD-6f6bfd4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 840M/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [ ]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#4

System Information for Support

Client Version                                Nightly 1224 HEAD-6f6bfd4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 840M/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [ ]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#5

Now it crashes when i enabled those configurations

Log
citra_log.txt (35.1 KB)

#6

System Information for Support

Client Version                                Nightly 1224 HEAD-6f6bfd4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 840M/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [ ]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#7

Enable ‘Enable Hardware Renderer’ and ‘Enable Shader JIT’

#8

Your graphics driver is outdated. Download the update here: https://www.nvidia.com.br/Download/driverResults.aspx/144435/br

Since you are on a laptop make sure in Windows that the power plan is set to high performance and then in Nvidia control panel select Prefer maximum performance under power management in 3D settings - global settings tab. If you also install GeForce Experience turn off “Battery boost”.