Citra keeps crashing when playing Dragon Quest 8

Issue:
I just started using Citra to play Dragon Quest 8, and the game keeps crashing after a few minutes. There doesn’t seem to be any particular trigger for the crash: it’s happened in the middle of the first battle, it’s happened during one of the first cutscenes, it’s happened while walking around the first town. It just takes a few minutes for the crash to happen.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 2500U
  • GPU: AMD Radeon Vega 8
  • Citra Version: Citra Nightly 1783
  • Game: Dragon Quest VIII (USA)

Diagnostic Log
citra_log.txt (4.9 KB)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

citra_log.txt (127.1 KB)

System Information for Support

Client Version                               Nightly 1783   HEAD-746609f
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx   | AVX2 | FMA
Graphics API                                 OpenGL 4.3.1
Graphics Renderer                            AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                           26.20.12036.1
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Go to Emulation > Configure > System and set the CPU Clock Speed back to 100%. You shouldn’t touch that setting unless you know what you are doing. Then try your game again.

If that doesn’t fix it, please upload a new log file.

1 Like

System Information for Support

Client Version                               Nightly 1783   HEAD-746609f
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx   | AVX2 | FMA
Graphics API                                 OpenGL 4.3.1
Graphics Renderer                            AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                           26.20.12036.1
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Ignore the previous log, that was a mistake. Setting the clock speed to 100% did not fix it. To be clear, it’s not merely Citra’s screen that turns to black after the crash, but the entire computer’s, which I then have to turn off manually by holding down the power button.
citra_log.txt (131.7 KB)

System Information for Support

Client Version                               Nightly 1783   HEAD-746609f
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx   | AVX2 | FMA
Graphics API                                 OpenGL 4.3.1
Graphics Renderer                            AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                           26.20.12036.1
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.

Update drivers to 22.8.2: https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-5-mobile-processors-radeon-vega-graphics/amd-ryzen-5

1 Like

Thanks! That seems to have done the trick :smile:

1 Like