Citra keeps crashing while trying to load Tomodachi Life (After loading the shaders)

Issue: Crashes after loading shaders for Tomdachi Life
Enter a description of your issue here, in full detail.
I have been playing Tomodachi Life for quite a bit, then it decided to fail on me by crashing when I wanted to play it the next time I tried to load it, so, in the loading shaders screen, it was completed, but then it crashes. citra_log.txt (4.7 KB)
System Information

  • Operating System: Windows 10 Home Single Language 64-bit (10.0, Build 18362)
  • CPU: Intel® Core™ i5-8265U CPU @ 1.60GHz (8 CPUs), ~1.8GHz
  • GPU: Intel® UHD Graphics 620
  • Citra Version (found in title bar): Canary 1640
  • Game: Tomodachi Life
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1640 HEAD-4f8f8e8
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

i have already enabled it, but it still crashes

citra_log.txt (9.8 KB)

System Information for Support

Client Version                                Canary 1640 HEAD-4f8f8e8
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) UHD Graphics 620
OpenGL Version                                3.3.0
GPU Driver Version                            26.20.100.7372
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

citra_log.txt (9.8 KB)

System Information for Support

Client Version                                Canary 1640 HEAD-4f8f8e8
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) UHD Graphics 620
OpenGL Version                                3.3.0
GPU Driver Version                            26.20.100.7372
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, I’m investigating a bit on this matter but in other games however I haven’t been able to replicate these crashes yet.

Do this to check something for me:

  1. Open Citra then File->Open Citra Folder
  2. Open shaders folder then opengl folder
  3. Screenshot the content in both precompiled and transferable folders so I can see how big the .bin files are in them.

1 Like

I have another game on my citra, It is pokemon sun… but it works just fine and doesn’t crash

Thanks! :slight_smile:

To fix this in the short term, turn off Disk Shader Cache in the graphics options. I will continue to investigate further in the weekend.

alright, thank you. be looking forward to it.

Oh, by the way, it already is working after i disabled it. the game is fine

Hello again, I was able to replicate the issue finally. First I need to ask you something, did the shaders always load from zero every time you started the game?

During my testing I was first playing with Accurate Multiplication turned on and only new shaders had to be loaded slowly while the rest loaded very fast. I built a bit larger transfer cache than yours and didn’t get the issue at first at over 18000 shaders. Precompiled was always less than transfer, around 36MB in my case with these many shaders and every time I started the game it remembered shaders that was in precompiled.

Then I was looking at your first log and saw Accurate Multiplication turned off so when I switched it off and started the game it was loading the shaders from scratch and when it finished the precompiled grew to 72MB and on my third load to 110MB. RAM usage also skyrocketed.

Yes, it had always loaded from 0/17800~

1 Like

Thanks for confirming :slight_smile: I will bring my findings up to the devs and hopefully this will get fixed in the near future. I cannot promise that though as they are busy.

Disk Shader Cache can still be used right now but you need to delete the opengl folder and turn on Accurate Multiplication.

okay, thank you so much for your help.