Citra lagging, can't find solution

Issue:
Hello, my problem is that when I play Pokemon Omega Ruby, I have very low fps about 20. I looked everywhere for solutions for a few days, constantly but just couldnt find any. I also have in some specific areas more than 20 fps, but even then they still drop to 10 often. I have also tested Pokemon X for a few seconds and then quit, after seeing the 10 fps in the bottom right corner.

Things I’ve checked:

  • I saw someone else with a Radeon having a similar problem, aka having laggs but it wasn’t as bad as it is for me, it was something with OpenGL, but I didn’t understand it at all
  • I’ve also deleted unnecessary stuff
  • I closed every tab I had open
  • I gave it high priority with Task Manager
  • I reinstalled it with Admin rights
  • Start it as an Admin
  • It also doesn’t use even close to 100% of my CPU, GPU or hard disk
  • I tested it with Pokemon X and it lagged too
  • Turned of Avira and Firewall when installing and playing
  • Let the installation and game bypass firewall too

System Information

  • Operating System: Windows 10 64 bit
  • CPU: I5 - 8600k
  • GPU: Radeon RX580 Sapphire 8gb
  • RAM: 16gb
  • Citra Version (found in title bar): Citra Nightly 1548
  • Game: Pokemon Omega Ruby/ Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar): http://prntscr.com/slb3d7

Diagnostic Log
citra_log.txt (95 Bytes)

(Also I am german so if there are any mistakes in my english, I am sorry)

Since you have a desktop computer you can try plug in your monitor to the motherboard instead of the graphics card and Citra will use the iGPU instead, see if that works better. You might need to update the Intel drivers to 8190: https://downloadcenter.intel.com/download/29557/Intel-Graphics-Windows-10-DCH-Drivers?product=126685

Another option is to dual boot Linux(e.g Ubuntu) if you want to get better OpenGL performance for your graphics card.

Thank you, it’s funny how I searched for a solution for like roughly 30 hours just to have your answer solve it right away (for other’s that may have this problem, it got solved by updating my graphics card driver again (did it just a few weeks ago) and moving it from one hard disk to another that had more space)

1 Like