Citra lags when running fire emblem fates only

Issue:
The speed is as low as 38%, FPS 11 when I am running this game only. However when running other games eg fire emblem awakening and omega ruby it works fine.

I ve tried below:
-set internal resolution to native
-untick hardware shader
-untick shader JIT
-prioritizing citra in PC control panel

Please help me, thanks in advance!

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 3450U with Radeon Vega Mobile Gfx 2.10 GHz
  • GPU: AMD Radeon ™ Graphics
  • Citra Version (found in title bar): Nightly 1730
  • Game: FIre Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (35.2 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1730 HEAD-a5d01c0
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3450U with Radeon Vega Mobile Gfx   | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Graphics
GPU Driver Version                            20.10.21.01 27.20.1021.1002
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

You should definitely re-enable Shader JIT. Disabling that just leads to crappier performance.

Regardless, the main issue here is your AMD iGPU. AMD has incredibly bad OpenGL drivers on Windows. To the point where you’d get around 3x better OpenGL performance on Linux. Its just that bad. There’s not much we can do about that unfortunately.