Citra LAN emulation

Issue:
I am using a Citra canary build. Whenever I try to join a public room or host a room myself nothing happens. Doesn’t double-checking on the room name give you a prompt? And when I try to create a room no message pops up saying anything.

citra_log.txt (16.8 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Canary 1262 HEAD-4b3def0
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Did you put your username and token on Emulation > Configure > General > Web ?

yeah i did. two green ticks.

You should be able to connect to public rooms then, to host a room you need to port forward citra’s UDP port (the one that you use to create a room) on your router/modem.

Open “Window Firewall with Advanced Security”, click on “Inbound Rules” and check there’s two entries for ‘citra-qt’ in green. also add an exception for citra-qt.exe on your antivirus, including defender.

I did everything you said. Still not working.
Enabled them in windows firewall and defender.
My antivirus licence expired two days back.

Close citra, find again the entries for citra-qt (and citra-room if any) on ‘Inbound Rules’ and delete them. open citra and launch a game, a firewall window message will appear, click to allow access, now try connecting to a room.

instead of using my lan i tried using my mobile as hotspot. now i am able to connect to the rooms. and can you tell me what port forwarding is? i want to host aroom.

that is something you have to do so other clients can connect to yours, just search it online “port forwarding + whatever connection type you are using”. port forward whatever (UDP) port you are using to create your room (default is 24872).