Citra loads the game, black screen with audio canary 1641 and nightly 1469

Issue: Black screen on games, audio is present.
Enter a description of your issue here, in full detail.
Was working previously with slight lag, I checked a previous thread due to some lag issues whenever the game would go to a black screen. It suggested I update the GPU drivers, of which I did, and then this issue came up. Tried other solutions in other similar threads such as tinkering with the hardware shading and rendering settings. Also tried reinstalling and reupdating and reverting my GPUs to the old ones and now back again to the latest update.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (20.0 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1641 HEAD-e9f68ae
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            445.75
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Yeah 445.75 is a buggy driver, 442.74 or 442.50 is fine. You might need to run DDU first before installing the older driver to make sure it’s a clean install: https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Try this too:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Hi there, I’ve tried out the suggestions you gave, still no luck. Also I was prompted to update citra to Canary 1644*. Also tried the second suggestion you gave and same issue persists.

citra_log.txt (4.3 KB)

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Sorry you most likely reopened Citra by accident before uploading the log :stuck_out_tongue: The log gets cleared every time you open Citra.

Oops my bad, lemme see if this one is correct now.

citra_log.txt (39.4 KB)

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            442.74
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            442.74
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

Hm, perhaps the rom is corrupted. Try redump using the guides below. Have at least 4GB free space on your SD card before you dump to make sure there will be no issues.


I’ve tried the suggestion, and no luck. However I think the issue is with the driver version. I uninstalled my nVidia driver and used the integrated graphics while it was uninstalled, and the game works again. I’ll revisit your former suggestion of using the other versions.

A new Nvidia driver released yesterday I believe, not sure if that has fixed the bugs caused with the previous or not(I’m still on an older version, 442.50 and it works fine here).

So far here are the versions that I’ve tried and unfortunately had no luck:

  1. 445.85
  2. 445.75
  3. 442.74
  4. 442.50

I’m very confused as to why this is the case. So far, it’s been working for the integrated intel graphics and the base version of my nVidia driver which is 378.49.

Okay long story short:

  1. Reverted back to nvidia version 378.49 and now it works.
  2. Frames issue was resolved when I underclocked the CPU to 60%

Thank you though for the responses, it helped me get to this conclusion :>

Strange how that is the case for you. I think it’s the first time I see this :stuck_out_tongue:

citra_log.txt (33.9 KB)

System Information for Support

Client Version                               Nightly 1737   HEAD-28039d3
Operating System                             Windows 10 (10.0)
CPU                                          11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz | AVX512 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) Iris(R) Xe Graphics
GPU Driver Version                           30.0.101.1191
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.