Citra Low speed on Pokemon sun

Issue:
Enter a description of your issue here, in full detail.
Hello
the speed of play during cinematics is slow and also during the movement can you help me please.

System Information

  • Operating System: Windows
  • CPU: AMD Ryzen 3 2300u
  • GPU: radeon vega 6
  • Citra Version (found in title bar): Citra Nightly 1389
  • Game: Pokemon sun / ultra sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (4.0 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1389 HEAD-866df26
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 2

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • CPU JIT should be enabled for the best performance. Please enable this option.

Yeah enable CPU JIT, it provides a speed boost. It’s enabled by default so you must have turned it off. It’s found in the Debug tab.

The log doesn’t say you started a game so make sure you do these steps:

  1. Open Citra then File->Open Citra Folder then log folder(keep this open in the background).
  2. Start the game, get where it’s slow on the overworld then close Citra(don’t reopen or the log gets cleared so you have to do it again).
  3. Reupload the log here.

okk i didn’t close citra before sending the log hhh
here the new log i enable CPU JIT but stil slow
citra_log.txt (55.4 KB)

System Information for Support

Client Version                                Nightly 1389 HEAD-866df26
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon(TM) Vega 6 Graphics
OpenGL Version                                3.3.1
GPU Driver Version                            23.20.826.9472
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 2

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I see, there is not much you can do because you have Radeon :confused: it struggles with OpenGL on Windows, it’s better on Linux though.

Get the latest drivers here: https://www.amd.com/en/support maybe that will help.

mmm nothing to do hhhhhh thx for your help anyway