Citra Nightly Crashes my PC: Late 2019-2020 Updates

Issue:
Hello! Upon downloading some of the newest updates (Starting from around December 2019) my Citra Nightly has seemed to have broken in some way. Each time I try to boot up a ROM (More Specifically Tomodachi Life and Animal Crossing New Leaf) the loading screen will appear but my whole computer will freeze before the ROM is done loading, causing me to have to manually shut down my Laptop and rebooting. I have tried to redownload the application multiple times, including the ROMS themselves, but nothing has worked. I have yet to find anyone with this problem as well. This problem will completely freeze my entire computer, not allowing me to do anything with it including opening task manager, close the app, take screenshots, or even move my mouse around. I am unaware of what version started this but it still happens with the newest update as well.

System Information

  • Operating System: Windows 10 Pro 64 Bit
  • CPU: 2.70 GHz
  • GPU: Intel® HD Graphics 4000
  • Citra Version: Citra Nightly 1547
  • Game: Tomodachi Life
  • Screenshot of Issue: Unable to receive

Extra Note: I apologize if anything on this is wrong, this is my very first time writing a report like this.

Diagnostic Log
citra_log.txt (5.3 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

1 Like

Hi, do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Thank you for taking the time to respond to me. Thankfully, your advice has prevented Citra from freezing my computer but sadly, the application freezes and stops working when I try to boot up a ROM. It just leaves me with a black screen, causing me to have to close the app with Task Manager

Ok, upload a new log please :slight_smile: Make sure you tried to start the game first before closing Citra and don’t reopen Citra or the log gets cleared so you have to do it again. Have the log folder in the background before starting the game.