Citra Nightly crashing FE echoes

Issue:
Hello! Citra Nightly closes when I press A to acess to the game menu from the opening cinematic in the game Fire Emblem Echoes: Shadows of Valentia.
My computer is old (2013 I think) and I can’t get GPU drivers more recent than 2019, is that the issue? Even though it supports OpenGL 3.3 from what I saw.

System Information

  • Operating System: Windows 10 version 1903
  • CPU: Intel Core i7-3630QCM CPU @ 2.40GHz 2.40GHz
  • GPU: NVIDIA GT650m
  • Citra Version (found in title bar): Citra Nightly 1659
  • Game: Fire Emblem Echoes: Shadow of Valentia (EU)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (4.7 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

Oh my bad, here’s the log after a crash without re-opening Citra.

citra_log.txt (42.7 KB)

System Information for Support

Client Version                                Nightly 1659 HEAD-3f13e1c
Operating System                              Windows 10 (10.0)
CPU                                                 Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

To update your drivers: Download win64_15.33.53.5161.zip (direct link) from https://downloadcenter.intel.com/download/29969/Intel-Graphics-Driver-for-Windows-15-33-

Then follow this guide on how to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, because your GPU has driver bugs, you may need to turn off New 3DS Mode in Emulation>Configuration>System to prevent crashing and freezing. If that doesn’t work, you’ll have to use an older Citra version until you upgrade your hardware:
Download citra-windows-mingw-20191214-ddb7ead.7z (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.

Lastly, make sure to re-enable Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab after you’ve followed all the previous steps for better performance.

I managed to install the updated drivers without an error message and needing to manually install it, but Citra still crashed.

I guess I’ll use the older version of Citra until I decide to get a new computer.

Thank you for your help and this great emulator!

If you mean you used the auto-detect feature on Intel’s site, then you likely do not have the latest drivers installed. If that tool could do that, we wouldn’t tell you to manually install the drivers in the first place. The guide I linked in my previous post explains why it doesn’t simply install the latest drivers.