Citra nightly lag, low fps

Citra runs at 30 fps while I’ve the minimum configuration

I’ve tried to play animal crossing new leaf or pokemon alpha but the game runs at 30 fps, I can’t play with this.
I’ve 1856 single thrad rating with my CPU and OpenGl version 4.6

System Information

  • Operating System: windows 10
  • CPU: AMD ryzen 3 3200U
  • GPU: AMD Radeon vega 3 graphics
  • Citra Version (found in title bar): citra nightly version 1458
  • Game: Animal crossing new leaf amiibo and pokemon alpha
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (97.3 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Pokémon runs natively at 30fps.

System Information for Support

Client Version                                Nightly 1468 HEAD-e480a80
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1468 HEAD-e480a80
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon(TM) Vega 3 Graphics
OpenGL Version                                3.3.1
GPU Driver Version                            20.4.1 26.20.15029.20013
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

So I can’t play at animal crossing, pokemon or others 3ds game ?
( I’ve put my log for some help)

If you want to play faster than normal game speed then unfortunately Radeon is not performing well with OpenGL on Windows if you still have only ~30fps with Limit Speed Percent turned off in the General tab in Citra configuration. You could try dual boot Linux(e.g Ubuntu) for more performance. The other option is to buy a computer with Nvidia.

Ok thanks that’s what i tought because my sister has a worse laptop than me but with a Nvidia and she doesn’t have lag.
Dual boot Linux makes citra faster ? I read the installer and it seems pretty big

Yeah Linux has open source Mesa drivers which boosts performance for Radeon with OpenGL applications like Citra. Here is a video to demonstrate the difference:

However it’s with RX 580 which is more powerful :stuck_out_tongue:

wow what a difference ! Yes RX580 more more powerful :laughing:
Ok thanks a lot, I keep you posted !

Have u try it btw? I have sama spec :slightly_frowning_face: