Citra Nightly not working

Issue:
Enter a description of your issue here, in full detail.
Citra crashes when attempting to load Pokemon Omega Ruby and Ultra Sun.

System Information

  • Operating System: Mac

  • CPU: Apple m1

  • GPU: 7core

  • Citra Version (found in title bar):

  • Game: Pokemon omega ruby and pokemon ultra suh

  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (9.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              macOS 11.3
CPU                                           VirtualApple @ 2.50GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The new M1 devices are not officially supported by Citra. Bugs and crashes like these are to be expected. You can read more abou this here: Apple M1 Chip on MacBook Pro

  • Operating System: Windows 10 Pro
  • CPU: Intel Core i5
  • GPU: dont know but the games were working and loading quite nicely before
  • Citra Version (found in title bar): Citra Nightly 1715
  • Game: Dragon Quest VIII
  • Screenshot of Issue (include the full Citra window including titlebar):

    hello, citra stopped working suddently and now any game I try to play it won’t load, before it wasn’t like this, I used to play the game but with a few lags and after a while it would crash and shut down please help
    citra_log.txt (13.5 KB)

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4252
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

this has happened with me too
but after the update it is working perfectly
did you try uninstalling Citra and then again installing it?

GL_VERSION: 3.3.0 - Build 10.18.10.4252

^ This driver is out of date. To update, download win64_15.33.53.5161.zip (direct link) from Download Intel® Graphics Driver for Windows* [15.33]

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, because your iGPU has driver bugs, you’ll need to use an older version of Citra in order to prevent random freezing and crashing from occurring until you upgrade your hardware:
Download citra-windows-mingw-20191214-ddb7ead.7z from Release nightly-1392: Merge pull request #5020 from jroweboy/dynamic-mf · citra-emu/citra-nightly · GitHub
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.

Lastly, because you had cheats activated whilst experiencing the issue, make sure to disable those and restart Citra (important, otherwise they remain active). Though, the steps I have given you above should already solve the issue. This is just to be sure.

hey thanks for helping but now I have another issue can you help me please
I am playing Dragon quest 8 and I have reached a stage in the game where I need to follow the shadow of a big bird to get ahead in the game but the shadow doesn’t show in the game
I tried to disable the hardware shader option from the settings but it shows me like this witch is useless

please help

citra_log.txt (4.9 KB)

citra_log.txt.old.txt (314.5 KB)

System Information for Support

Client Version                                Nightly 1716 HEAD-62236b7
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Please use the older Citra version as I instructed you to earlier. If the problem remains there, please upload a log file.

I did as you told still no shadow
citra_log.txt (8.1 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close Citra if it doesn’t do so by itself. Do not restart Citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

ok I did now, the shadow it does appear if I disable an option from the advanced graphic settings of citra but the emulation speed of the game slows down to 3 per cent witch makes it almost impossible to play it
citra_log.txt (282.1 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics

I hope I did it correctly this time

Most likely Hardware Shaders. This might just not be solveable then. What Hardware Shaders uses to emulate the shadow are OpenGL extensions that your Intel HD 4000 simply doesn’t support. It was Intel’s first iGPU that supported the OpenGL 3.3 spec and because of that, it didn’t support it correctly everywhere. This is just one of those places where it didn’t.