Citra Nightly won't open after update

I didn’t use Citra for a while and I decided to open it again and update it, but after installing the latest Citra Nightly build my Citra won’t open at all. I’ve downloaded the latest Visual C++ 2015-2022 runtime version (14.36.32532.0), I’ve tried uninstalling and reinstalling, tried some of the older versions but I don’t want to spend all my time downloading and trying each version until it works so I stopped at version 2000. As far as I can tell my CPU and GPU drivers are up to date, and my log files are empty since Citra won’t open. I have no idea what the issue is and I’m wondering if I just have to wait for a new Citra Nightly build for my problem to be fixed.

System Information

  • Operating System: Windows 11
  • CPU: AMD Ryzen 7 5800H
  • GPU: NVIDIA GeForce RTX 3060 Laptop
  • Citra Version (found in title bar): 2014
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Go to Release nightly-2015 · citra-emu/citra-nightly · GitHub and download citra-windows-msvc-20231021-2416258.7z . Extract it using winrar or 7zip, and launch citra-qt(.exe) found inside of the extracted folder. Let me know if this solves your issue.

Unfortunately no I had the same issue, I tried some of the previous versions of nightly, (from 2013 to 2000 I think) and all of them had the same problem

Hmm, in the manual build you’ve just downloaded, create a folder called user in the same location as its citra-qt(.exe). Then launch citra-qt(.exe) again. See if that changes anything (this should put the build in portable mode).

When I try that the Citra Nightly build loads but then immediately stops responding again. I checked the log in the user folder but its still empty

And you’re positive you downloaded the MSVC build, correct?

citra-windows-msvc-20231021-2416258 right?

Yes. Hmmm, let’s try updating both your GPU drivers to rule that out. It’s good maintenance anyways:

For your integrated AMD GPU:

For your dedicated NVIDIA GPU: GeForce Game Ready Driver | 545.84 | Windows 10 64-bit, Windows 11 | NVIDIA

Update both, then restart your laptop (if the driver installer doesn’t make you do so already). Then try Citra again. Make sure to leave your PC alone whilst it’s updating your drivers. Don’t watch videos or the like, just let it install properly.

I already tried updating my drivers before but I decided to double check. I previously installed amd adrenaline and it said my drivers were up to date, so I uninstalled it. This time I tried downloading the drivers only option and it managed to fix the problem. Thanks for the help.

1 Like

Yea, automatic driver updaters can be a bit finicky. It’s generally best to just update manually to be sure.

Said it before. You guys need to make Citra compatible with lower systems and/or software (since he did say it was a Windows 11).

That or make a third version (call it Compatibility Version or something).

When making a toaster, do you require toaster software 2.9 before bread will toast? Or is it ready to toast bread regardless?

When I write books, I write them for myself. However, if you want something people will use, power or speed always comes second to usability. I’m posting this sentiment twice in hopes the Citra engineers might get the memo. Might be wasting my breath though.

We don’t know the cause yet why Citra freezes on startup on Ryzen APUs running old drivers (or provided by Windows Update).

For older systems there are legacy builds: Citra Legacy Builds - Citra

Even Valve is dropping Windows 7, 8 and 8.1 support starting in 2024:

Older versions of Windows provide a security risk, they really should consider upgrading if they haven’t already. Microsoft dropped support a few years ago.