Citra No Longer Receives Input From My Keyboard

Issue:
I was playing Pokemon Alpha Sapphire and everything was running smoothly until suddenly I could no longer move my player, open the menu, etc. It’s not lag, as it’s running at a fair FPS; it’s not my keyboard because it works fine on any other program; I tried uninstalling/reinstalling Citra, and I even tried a different Alpha Sapphire file in case mine was corrupted. I tried changing the configurations and restoring them to default. Nothing worked. I can no longer use Citra at all because the program doesn’t register anything I press on my keyboard. No matter the game file I load, I can’t get past the menu screen because it just does not register despite the fact that my keyboard works perfectly fine. Can someone please help me?

System Information

  • Citra Version: Citra Nightly | HEAD-3bd1cd0
  • Game: Pokemon Alpha Sapphire

did you try to delete the qt-config.ini at: (backup this file first for safety)
C:\Users\your_username\AppData\Roaming\Citra\config

Can you screenshot the input config tab?

That AppData folder doesn’t seem to exist, and the Roaming folder is empty.

Here is a screenshot of the input tab. They should all be default because they’ve already been reset.

Oh, and as a side-note, I also tried installing Canary just to see if that would work instead of Nightly, and I still had the same issue.

AppData is a hidden folder you can only see if you put on the settings to show them:
Here is a guide:
https://www.howtogeek.com/howto/windows-vista/show-hidden-files-and-folders-in-windows-vista/

In AppData there are always three folders, Local, LocalLow and Roaming.
In Roaming there are a bunch of folders from different applications saving different stuff on your computer.
In the case of Citra you should find one Citra folder with config, log, nand etc.
In config there is the qt-config.ini (your settings are stored here).

I guess the theory is if the config file is broken and not overwritten by a new installation deleting tmight fix your issue so new installations wouldn’t load the old config but create a new file.

Okay, I tried deleting the qt-config.ini file, and unfortunately it didn’t solve the input issue. :frowning:

Running the program as an Administrator worked.

I guess my computer just kinda decided Citra didn’t have permission to use the keyboard.

1 Like

I’m not sure how to help you other than try a new install now and maybe trying out a Gamepad if you have one?
Do at least the hot-keys work like esc, F9, F10, F11 and so on?

You could also delete the whole Roaming folder but be sure to backup your savefiles if they are needed.
You can right click on the games in your gamelist and click on “open save data location” back up the file or go far enough back to the Roaming/Citra folder and just backup the “sdmc” folder with all your save files.

Your issue appear strange, a possible solution would be desirable.

did you change anything on your windows settings like adding a new keyboard language layout?
if not do you use multiple keyboard layouts?

Even this didn’t solve for me.

For anyone who still has this problem, run Citra in Administration mode. Works for me.