Citra not reading cheats file

After downloading the latest update to Citra Canary and booting up Pokemon Ultra Moon, my cheats disappeared. The text file still exists, but the cheats… it just isn’t reading them anymore. I tried adding the cheats back in manually, yet the moment I closed the game, they disappeared again, as the it stopped reading the text file. I’m not sure what the problem is, they worked completely fine before, was something accidentally broken in the latest update?

System Information

  • Operating System: Windows 10
  • CPU: 11th Gen Intel(R) Core™ i7-11700F @ 2.50GHz
  • GPU: NVIDIA GeForce RTX 3070
  • Citra Version (found in title bar): Citra Canary 2418
  • Game: Pokemon Ultra Moon v1.2
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (68.0 KB)

The cheats do work if I manually input them, but having to input the cheats every single time I want to use them, especially when I use the remove outlines cheat just to make the game look better, is frustrating.

Where exactly is that cheats .txt file located?

in the area it’s supposed to be. AppData/Roaming/Citra/Cheats

And to confirm, when you go to File>Open Citra Folder in Citra, it opens up to AppData/Roaming/Citra?

Yes, it does. It was working perfectly fine before I updated, too.

After you save the cheat code, does the cheat file update itself at all? It’s supposed to write to the cheats file for that game when you save it.

Hey! I’m encountering the same issue as this person, and yes, the cheat file does update itself after you save a cheat.

I was able to reproduce this on the latest Canary build, but not the latest Nightly builds. Which means one of the new PRs is the cause of this. I’ll investigate whichever one broke it and inform the relevant dev. Thanks for the reports you two!

1 Like

Alright, this issue should be fixed in the latest Canary builds.