Citra not running normally (nan ms)

Issue:
Enter a description of your issue here, in full detail.

yesterday te emulator was working just fine, but today when I tried to run my games, it simply makes the emulator slow, and the game wouldn’t run at all, the menus worked, but very slow, I tried to reinstall it but to no avail, sorry for the bad english

System Information

  • Operating System: win 10
  • CPU: any
  • GPU: any
  • Citra Version (found in title bar): 1621
  • Game: any
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hi, try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.

Utility_CustomTextures: true

Try turn off custom textures.

Done both, but nothing changed, it tries to load but then it gets stuck

Try disabling “disk shader cache” in emulation>graphics>utility.

Done it, still the same, by the way, I also installed another emulator (android) on my pc, does it have any sort of conflict with citra?

Not that I know of.
There’s not much I can think off that would cause your issues…
Could you maybe provide your GPU and CPU?

I don’t really understand about this stuff is this it?

Computer Information:
Manufacturer: Acer
Model: Aspire V5-471
Form Factor: Laptop
Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i3-3217U CPU @ 1.80GHz
CPU Family: 0x6
CPU Model: 0x3a
CPU Stepping: 0x9
CPU Type: 0x0
Speed: 1796 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Unsupported
AVX: Supported
AVX2: Unsupported
AVX512F: Unsupported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Unsupported
AVX512VNNI: Unsupported
SHA: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: Intel® HD Graphics 4000
DirectX Driver Name: igdumdim32.dll
Driver Version: 10.18.10.4252
DirectX Driver Version: 10.18.10.4252
Driver Date: 7 10 2015
OpenGL Version: 4.0
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: Intel® HD Graphics 4000
VendorID: 0x8086
DeviceID: 0x166
Revision: 0x9
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 12.17" x 6.85" (13.94" diag)
30.9cm x 17.4cm (35.4cm diag)
Primary Bus Type Not Detected
Primary VRAM: -1920 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Alto-falantes (2- High Definition)

Memory:
RAM: 5939 Mb

I got this from the steam app

Let’s update your drivers first.
Download win64_15.33.51.5146.exe from https://downloadcenter.intel.com/download/29802/Intel-Graphics-Driver-for-Windows-15-33-?product=65697
Direct link: win64_15.33.51.5146.exe

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Lastly, because you have a troublesome GPU for citra, you want to be using an older version of citra.
Download citra-windows-mingw-20191214-ddb7ead.7z from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392
Direct link: citra-windows-mingw-20191214-ddb7ead.7z
After you’ve downloaded it, extract it using 7zip or winrar to anywhere you want. Inside the extracted folder you should find cita-qt.exe. Whilst the next step isn’t particularly necessary, it might be good to do in your case --> Create a folder called ‘‘user’’ in the same folder as citra-qt.exe. This will make citra create all the folders it usually creates in the default install location in that ‘‘user’’ folder instead. Meaning it will be a fresh intall (this also means your save won’t be there when you load your game).afbeelding
After you’ve done all that, run citra-qt from the folder and launch your game.

1 Like

It’s working! Many thanks!!! I wonder what could’ve caused that problem though, also, does this mean that I cannot update the program and I should leave it as is, as long as it works? Again, many thanks and sorry for the trouble!

If you’re now using the nightly 1392 version, you should not update citra until you upgrade your hardware. Your current GPU is simply not very compatible with the latest citra versions. As for what might’ve caused your issues, could have be a lot of things. Could have been permission issues in Appdata (where citra usually stores game and config data) or maybe, like I already mentioned, your GPU didn’t wanna play nice with the latest citra versions. It’s probably not worth spending the time to figure out exactly what the original problem was.