Citra not using dedicated GPU (AMD)

Issue:
I’ve been trying to use my dedicated to use my dedicated GPU (Radeon RX560X 4GB) instead of my non dedicated one. Im sure it’s a issue with Citra since trying to force it to use my dedicated GPU wont work but it works for every other programm. I tried both adding it to graphics settings under windows and under my drivers itself.

System Information

  • Operating System: Windows 10 Home
  • CPU: AMD Ryzen 5 3550H
  • GPU: dedicated: RX560X, non dedicated AMD Radeon Vega 8 Graphics
  • Citra Version (found in title bar): Citra Canary 1830
  • Game: Pokémon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (100.4 KB)

System Information for Support

Client Version                                Canary 1830 HEAD-55b529b
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                            20.8.1 27.20.2001.13001
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 0
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

How is switchable graphics currently setup in Radeon Settings?

Double check with the article: https://www.amd.com/en/support/kb/faq/dh-017

exactly like in the article. Tried it both in the drivers and under windows’s graphics settings.

I see, however even if it would work you probably will be disappointed by the performance since AMD GPUs are crippled with OpenGL on Windows but on Linux (e.g Ubuntu) it’s ok. You could go for a dual boot setup if you would want that.

Okay thanks! I will try that.

It may be too late but at least someone in the future can read this.

I had the same issue bc I had a 6600xt (which I know vulkan dsnt run too well) and a 1660

I tried a lot of things but Citra wouldn’t change to the 1660, so I deactivated the 6600 in the bios, started citra, and then it worked.

When I activated the 6600 again Citra continued using the 1660.

Hope this helps someone

GTX 1660 I assume? You can manually set the OpenGL renderer for a specific program in NVIDIA’s Control Panel (Manage 3D settings>Program settings), as well as Radeon’s equivelent (though harder to do on AMD’s side).