Citra on MacOS High Sierra, black screen

I updated my MacBook Pro mid 2012 to High Sierra and installerò Citra but when I RUN a game a black screen appears. At the bottom I can see Speed % and FPS working but no images. Why?
Thank you!

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

1 Like

try disabling ‘Enable Hardware Shader’

Thank you!
Where do I find this setting?

Emulation > Configure > Graphics and uncheck the ‘Enable Hardware Shader’ checkbox.

Thank you very much!
I’ll let you know if this works in a min.

also, upload your log.
Emulation > Configure > Debug.
click on ‘Open Log Location’ and leave that folder open.
run your game, when the problems occurs close citra.
and on that previously opened folder, upload the citra_log file in there.

1 Like

Thank you!
So I tried the first option and configure doesnt show, here’s the pic

my mistake, on mac it’s probably under Citra, or any other menubar item.

Don’t worry, found and did as you said and it worked! Thank you very much for your help!
Wanted to ask is there a way to speed up games? It’s a bit slow. (37 FPS)

there are some problems on some computer configurations currently, it also depends on the game.
on can try to enable ‘Enable Hardware Shader’ and also enable or disable the two other boxes ‘Accurate Multiplication’ and ‘Accurate Geometry Shader’, some configurations may work.

additionally provide your log. it does help nailing down bugs.

Disabled hardware shaders and automatically the other 2 options became grey, I think they’re disabled right?
Ok I’ll provide the log. Thank you!

yes you have to check ‘Enable Hardware Shader’ to enable those options, playing with them may yield different results.

Disabled them all but it doesn’t work unfortunately

you will have to wait until a fix comes along, btw which games have you tested?

Ok Thank you for your help!
New Super Mario Bros 2.

Noticed that when I disable shaders image works but slow and when I enable it image is bad but faster. Why?

it’s buggy currently, ‘Enable Hardware Shader’ purpose is to improve performance.

That’s why. Thank you!
So I have to wait for bug fixes I guess.