Citra only plays audio, game screen blank

I downloaded citra about a week ago, and so far it’s been working fine - except for this weird thing where when I first load a game, it flashes the game’s screen for one second before disappearing completely. The citra screen isn’t black, it’s just blank - but it’s playing the game’s audio. However, I could work around it by switching from the citra window to a chrome window - for whatever reason, the game’s visuals would show normally after I did that. Except today I went to open it up as usual and, for no apparent reason, the chrome workaround doesn’t work. Nothing’s changed between today and yesterday, the only vaguely related thing I could think of is that the last time I played I set emulation to pause when I switch windows - I changed it back just in case it was that that was causing the issue, but to no avail. I’ve tried both the nightly and canary builds but nothing seems to improve.

System Information

Diagnostic Log
(both canary and nightly)

citra_log.txt (28.2 KB)

citra_log.txt (26.4 KB)

System Information for Support

Client Version                                Canary 1571 HEAD-897b370
OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) HD Graphics 6000
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1425 HEAD-59c159e
OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) HD Graphics 6000
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I tried enabling it (even though I get a pop up telling me that that function is broken on mac) but nothing changes

Hm, I heard recently on macOS there is a bug but can be solved by resizing the window or toggle fullscreen(F11).

1 Like

Holy shit, that worked. Thank you so much, I was losing my mind over this.

1 Like