Citra oras problem with pokeblock case


#1

Issue:
Enter a description of your issue here, in full detail.
When I am playing normal game, the fps is 35 - 40 . But when I try to make a pokeblock using the pokeblock case , the fps drops to 6 - 10. It only happens when I try to feed the pokemon a pokeblock . Also the emulator lags too.

System Information

  • Operating System: Windows 10
  • CPU: Intel i3 6100
  • GPU: Intel 530 HD
  • Citra Version (found in title bar): D76693C
  • Game: Pokémon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar ) : how to ???

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (283.0 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296


#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.


#3

For clarity, this should be the full text in the title bar.

Your CPU is pretty decent but your iGPU is a very limiting factor and with more reliance on the GPU lately, its going to stress your GPU even further.

There are some new more accurate features added to Canary recently (accurate multiplication) and (accurate geometry shader), have you tried disabling these?


#4

this problem happens with me too, fps drop on pokeblock menu" givin it to pokemon"
and some random freeze and crash in the game.
Citra Last Canary “OpenGL”
CPU:AMD FX6300
8GB RAM
GPU:R9 270X Saphire dual 2GB


#5

when I disable those there is only a increase in +4 fps or else its the same like in 11 fps from 5 or 6 fps.


#6


#7

Dude, it’s may not be the ideal solution, but i think this can help.

When in pokeblock or about to open it, to to emulator Configure > Graphics > and change the internal resolution to 400x240.
After finish with pokeblock and exit that menu, to to Configure > Graphics and change back to automatic.

Works fine with me and i’m using onboard graphics (i5-7500, 8gb ram ddr4 and Intel HD Graphics 630).

Hope this helps and sry about my english, i’m improving it.