Citra problem Dll files

Hi there. I’m kinda new here so it’s probably gonna be a noobish question, but whatever.
I have a problem with DLL files when running Citra (latest build, or any other). The “missing api-ms-win-core-ectect” kind of thing.
The thing is, I have a Visual C++ 2015 installed, or so it says in my control panel - programs directory. But I still have those dll messages not letting me even run emulator properly!
I’ve tried downloading needed dll files from internet and installing them manually. And it works for this dll file, but Citra gives me another problem then. Like, it misses “api-ms-win-crt-string-l1-1-0.dll”, I downoald and istall it, and the next thing Citra needs is “api-ms-win-core-file-l1-2-0.dll”. And the list goes on and on. Does it mean I have to download all of them?
Something just isn’t right.

You need the redistributable which contains all of those dlls and puts the in the correct spot. Don’t ever download a dll and put it on your computer. A dll is basically an exe file without the ability to double click to run it, meaning if you downloaded a malicious dll file, and citra or any other program loads that file, then congrats on your new infected computer.

Install the msvc redistributable like the faq says to do and install that. If that still doesn’t work because your windows install is that borked, then you can run bleeding edge which is compiled with a different compiler and doesn’t need the redistributable.

Also important DLLs usually come packaged in groups or program with installers. If you already have some DLLs installation of a new pack / group of DLLs might fail (silently or with error). So to not break your system: only ever install DLLs with official setups by the instance who created the DLL (in most cases: Microsoft, GNU / MinGW, nvidia, AMD, …)

Well I have Microsodt Visual C++ 2015 Redistributable, but everything doesn’t work still.


And by the way I had dll problems even with Skyrim, and installing a dll file manually actually helped.

im having the same issue did anyone ever figure it out?

@Riley_Wright, Please don’t bump age old posts.
Make a new post, with a proper screenshot of what you are experincing, and support will be provided.