Citra-qt app doesn't open in the first place

Issue:
Enter a description of your issue here, in full detail.

I have downloaded Citra and tried to open citra-qt, only the terminal opens which instantly says that the task has been completed. The actual citra system where I need to initiate the game does not run in the first place. Please provide me with step-by-step process to fix this.

System Information

  • Operating System: macOS Sierra 10.12
  • CPU: 1.6 GHz Intel Core i5
  • GPU: Intel HD Graphics 6000
  • Citra Version (found in title bar): Title bar not present(version I downloaded was a96f0f5; most recent one, but I have tried downloading all available ones; didn’t work)
  • Game: Any
  • Screenshot of Issue (include the full Citra window including titlebar):

There is not screenshot because citra window doesn’t open; only the log

Diagnostic Log

Upload your log file as an attachment by dragging & dropping.

Last login: Wed Sep 26 22:49:58 on ttys000
You have new mail.
/var/folders/cw/bxsqq8vx2317y12x5lr8hkq80000gp/T/AppTranslocation/E69757DE-56D2-4498-8D25-2C803A8DC08B/d/citra-qt.app/Contents/MacOS/citra-qt-bin ; exit;
Jenny-ui-MacBook-Air:~ Johnathan$ /var/folders/cw/bxsqq8vx2317y12x5lr8hkq80000gp/T/AppTranslocation/E69757DE-56D2-4498-8D25-2C803A8DC08B/d/citra-qt.app/Contents/MacOS/citra-qt-bin ; exit;
dyld: Symbol not found: __ZdlPvSt11align_val_t
Referenced from: /var/folders/cw/bxsqq8vx2317y12x5lr8hkq80000gp/T/AppTranslocation/E69757DE-56D2-4498-8D25-2C803A8DC08B/d/citra-qt.app/Contents/MacOS/citra-qt-bin
Expected in: /usr/lib/libc++.1.dylib
in /var/folders/cw/bxsqq8vx2317y12x5lr8hkq80000gp/T/AppTranslocation/E69757DE-56D2-4498-8D25-2C803A8DC08B/d/citra-qt.app/Contents/MacOS/citra-qt-bin
Abort trap: 6
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

[Process completed]

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

This is a known issue (use Search) & has already been reported. However, there’s no ETA on a fix.

There’s no way of fixing it at all?

This issue doesn’t show up in a search. How is anyone supposed to know what search terms to use? I mean, I tried “citra exits macos”. “Citra crash macos”… Besides, this is a brand new issue, unless it’s on the front page, and unless it comes up when doing a search which it doesn’t, then it’s not redundant as far as anyone is concerned. Anyways, I have the same issue.

Did you try searching for “Mac terminal”? I personally don’t use a Mac, so I don’t have the details. But the developers know of this issue, but I’m not sure why it isn’t on GitHub.

EDIT:
This happens only in macOS 10.12 or lower. This is due to an update to the build bots.

operator delete, symbol not found.
I saw a post on reddit that there’s an older version that did function. I’m new to citra, but curious as to
what’s making this bug.
Is this a conflict between apple clang and homebrew clang?
Going to check this out.
------ edit ------
Bug introduced after nightly 977.

The problem is on this file /usr/lib/libc++.1.dylib but I can not open the file and add that missing piece (__ZdlPvSt11align_val_t)
I have the same problem

you don’t add it. its just something missing from mac 10.12, you need to update to at least 10.13 or later now

if i install the file from other mac with had 1.13? i can?
Or download from internet

No, it won’t work. It’s a Mac problem, not with Citra specifically.

Thanks for the explanation… it would be nice if system requirements were mentioned and updated somewhere.

Developers are trying to fix this issue. But probably the requirements will be bumped to 10.13 (NOT SURE)

I have upgraded to macOS high Sierra, and it works now! For anyone who has the same problem as I did, make sure your OS version is 10.13 or higher.