"citra-qt" (canary) runs game (Kingdom Hearts 3D) slower than "citra.exe"

Issue:
Hi
I’m trying to play a game on my pc that is Kingdom Hearts 3D: Dream Drop Distance.
If i open KH 3D dragging the game from the desktop on the application “citra.exe” of the canary build, then it will run perfectly, but if i open “citra-qt.exe” and launch the game from that interface, it will run a lot slower than the previous one opened in the other way.
I’d like to open the game by “citra-qt” because then i could configure my gamepad to play the game; if i opened the game with “citra.exe” then i wouldn’t be able to set the controller because there are no settings opening the emulator in this way.
However if i do the same thing with the nightly build, thus i open the game in both ways i said before, the game will run slow in both cases, so i’m planning to use the canary build.
Is there a way to solve this?
Or at least a way to use the gamepad also opening the game with citra.exe
I tried creating a log file but maybe since mine it’s not properly a bug and the game doesn’t crash the file i managed to create is empty.
Sorry for my bad english, i hope everything is clear and thanks in advance.

System Information

  • Operating System: windows 10
  • CPU: AMD Ryzen 3 1300X
  • GPU: PH-GTX1050 Series
  • Citra Version (found in title bar): Citra Canary HEAD-6816da1
  • Game: Kingdom Hearts 3D: Dream Drop Distance

I have experienced this too. I was playing Pokemon Alpha Saphire at my friend’s but a different citra build which I don’t remember and when we tried citra.exe it worked completely fine with a good speed, but the controls were too hard and there was no configuration settings so we ran it on citra-qt but it was a lot slower than the citra.exe, is there any way where we can improve the fps speed on citea-qt.

How much slower is it? I’ve never noticed this before.

Note that the settings for citra.exe can be configured in the sdl2-config.ini file located in %AppData%/Citra/config.

1 Like

Oh thanks i didn’t know that, tomorrow i’m going to try.
However when i run it on citra.exe i think the game runs perfectly or at least almost(I can’t say it precisely because you don’t see fps and the percentage of speed on citra.exe), on citra-qt around the 70 % of the speed.

I tried to configure the gamepad with the file “sdl2-config” in %AppData%/Citra/config
I copied the gamepad configuration from the “qt-config” and pasted it on “sdl2-config”, but when i open “citra.exe” the gamepad just doesn’t work and neither the standard configuration, i also opened the game with “citra-qt” and the gamepad was working.
I canceled the gamepad configuration again on “sdl2-config” and the standard button configuration came back to work.
Well I think for now I will play the game with the keyboard, as difficult as it is.

I also noticed that the touch controls on the bottom screen are not working on citra.exe, while on citra-qt they work.

I downloaded the latest version of the canary build for Windows, it came out a few days after the one i had and now citra-qt works great with KH 3D, i’m really happy and i’m really sorry if I wasted your time, but i didn’t notice there was an update.
Thanks anyways.