Citra-qt deletes itself?

I tried running Citra for the first time now, but whenever I run citra-qt, I get to the menu where I can select the directory for the games. Once I open the game, citra-qt just closes and the citra-qt.exe file disappears. I already have deactivated any windows defender program and so on, but it still happens for some reason. I also tried it manually, doesnt work either.

Has this issue occured to other people as well?

  • Operating System: Windows 10

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I cant even create a log because the .exe file deletes itself

Restart your computer and reinstall citra.

Tried this already too, doesnt work either…

Click on the link bellow and choose Manual Download, after extract to any folder and test it:

I did this too, as I said in my post, but unfortunately this doesnt work either :confused:

I have the exact same issue, except I am on Windows 8.1 operating system. Exactly same issue though, any time I try to get it to run a game, it will just delete the qt file, in both canary and nightly.

try this:

ignore the last sentence, if your game needs system archives you will need to copy to this user folder, mimicking the same layout of C:\Users\%username%\AppData\Roaming\Citra\
i.e user\nand and user\sdmc, however, it’s important to only copy system archives, the idea is to have a fresh user directory.

Theres two important things to note here that people seem to be misunderstanding:

  1. Applications on windows cannot delete themselves without being very creative. (Aka doing something like launching a detached child process with a different name and watching for the exe to finish and then delete the exe) Citra obviously doesn’t do anything like that.
  2. Citra_qt doesn’t have any code in it that deletes any files at all. (Technically the core application can delete files in the user folder, but we do not have any reference to the current running application directory anywhere in the code except for checking if the application is running in portable mode)

Both of these together should very STRONGLY suggest that an external application like a virus scanner is deleting the program.


I am having the same problem with my citra. I already tried the things told in the comments below but nothing works. Please give a solution

Well, when I run citra the first time, Avast told me that Citra-qt.exe was a virus, but Avast let me chose ignore it and then the program started normally. So I think that you have to add the .exe of citra in the list to ignore of your antivirus

1 Like

same problem here, after first launch, qt exe dissapears, same when i disable my antivir…

Sometimes windows defender will automatically recognize a .exe file as a threat and remove it. Rather than deactivating windows defender, you should add the file to the exception list.


Yes this has happend to me too but it was a malware issue and i had to use a bunch of malware cleaners like hitman pro and adware cleaner hope this helps. The problem is now fixed.

happened to me too, plz help me:

Typically it has to do with your antivirus detecting a false positive and deleting it.