Citra-qt.exe has stopped working (Tried to load Animal Crossing New Leaf)

Issue:
While trying to run Animal Crossing New Leaf (its the only one I play, I´m not sure if the error could/would persist in other games), Ive stumbled upon the Citra-qt.exe has stopped working error. Already searched for updates in my GPU, and there’s none available. I’m not quite sure what to do anymore. Please help, I don’t want to lose my village ):

System Information

  • Operating System: Windows 7 Ultimate
  • CPU: Intel Core i5-4570 3.20 GHrz
  • GPU: NVIDIA GeForce GT 520
  • Citra Version (found in title bar): citra nightly 1438
  • Game: Animal Crossing New Leaf
  • Screenshot of Issue (include the full Citra window including titlebar):
    citra_log.txt (12.7 KB)

System Information for Support

Client Version                                Nightly 1438 HEAD-ad3c464
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GT 520/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            391.35
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

It doesn’t seem to be an update available. The GeForce experience says my drivers are up to date. I’m not sure what to do.
Already tried looking for them manually and in other webpages
Just a few days ago it was working completely fine.