Citra-qt has stopped working at the middle of my play

Issue:
Hi guys, I have been playing bravely default on citra since some weeks ago, but an issue have been appearing constantly, the citra emulator crashes when I am playing, it could be at any moment (when I have 10 min playing or even 1 hour playing). Thing is, is that is a bit annoying when I could finally beat a boss and then crashes at the victory time, so yeah, i have to play it once more. I do not know why it could be happening so I left my log here.

Thanks in advance, if any support could be given.

System Information

  • Operating System: Windows 8
    Intel® Core™ i5-5200U CPU @ 2.20GHz 2.20GHz
  • Citra Version (found in title bar):
  • Game: Bravely Default
    citra_log.txt (140.7 KB)

System Information for Support

Client Version                                Nightly 1589 HEAD-96fa75f
Operating System                              Windows 8.1 (6.3)
CPU                                           Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 5500
GPU Driver Version                            10.18.15.4248
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

GPU Driver Version: Build 10.18.15.4248

This driver is outdated, you need to update.

Download win64_15.40.45.5126.zip from https://downloadcenter.intel.com/download/29474/Intel-Graphics-Driver-for-Windows-15-40-?product=85212
direct link: https://downloadmirror.intel.com/29474/a08/win64_15.40.45.5126.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Since you have an old GPU, you might need to use Nightly 1392 until you upgrade your computer to prevent crashes due to driver bugs: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

Hi Trywald, thanks. When I check out the autobot response I found out that citra was running by the default graphic card controller, that is the intel one, so I when to the Nvidia panel to add Citra to it, TBH I do not know why it was set by default like that, as I have all my programs running through the NVIDIA.

I was able to play today 5 hours non stop.

Oh you have Nvidia? Great, yeah that will run much better :slight_smile: Which one is it? Its drivers should be updated too if it’s not.

Indeed it has, though some scenarios runs on low FPS, but they are just 3 or 4. It is a GeForce 940M, and yes, it is updated :blush:

1 Like

Ah ok, so at the home screen in Nvidia Control Panel it says 451.67 ?

Since you can run on Nvidia now, you should do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Just did it, let’s try those areas and will et you know. Thanks!

1 Like