Citra-qt Has Stopped Working Issue

Issue:
First time using Citra and usually able to pick up on most things technical, so figured this would be no problem. However, while doing everything correct, upon trying to load up and play the Pokémon Y Version ROM, I get the following error message: “Citra-qt has stopped working”.

System Information

  • Operating System: Windows 7 Home Premium
  • CPU: Intel(R) Core™ i5-3210M CPU @ 2.50GHz
  • GPU: Intel(R) HD Graphics 4000
  • Citra Version: Canary 1970
  • Game: Pokémon Y Version
  • Screenshot of Issue:

citra_log.txt (10.9 KB)

System Information for Support

Client Version                                Canary 1970 HEAD-7ee5bf9
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz | AVX
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [ ]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • CPU JIT should be enabled for the best performance. Please enable this option.

It looks like you’re attempting to run an edited ROM file. Does the base ROM have the same issues? If so, please run that and then upload another log file.

The ROM is edited, as it was planned for a randomizer nuzlocke. I’ll double check to see if the original ROM has the same issue as soon as possible, however.


As per your suggestion, I dealt with the base ROM after removing the edited/modded ROM. Once that was done, it once again gave me the same issue shown above.

citra_log.txt (4.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log file you uploaded didn’t record your boot attempt. Meaning that you might’ve missed a step in the log file guide. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close citra if it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

Ah I see what I did wrong with that. Thank you for that. Here’s the updated log file with the issue present.
citra_log.txt (6.2 KB)

System Information for Support

Client Version                                Canary 1970 HEAD-7ee5bf9
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz | AVX
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It’s apparently not getting to the point where the OpenGL renderer is recorded.

Please right click on your windows start button and select Device Manager. Then expand the Display adapters tab and tell me what it says there (there may be more than one):
afbeelding

The Display Adapters tab shows Intel(R) HD Graphics 4000

Because your iGPU has driver bugs, you’ll need to use an older version of Citra in order to prevent random freezing and crashing from occurring until you upgrade your hardware:
Download citra-windows-mingw-20191214-ddb7ead.7z from Release nightly-1392: Merge pull request #5020 from jroweboy/dynamic-mf · citra-emu/citra-nightly · GitHub
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.

Followed the directions above and ran citra-qt.exe from the extracted folder to run the game, however yet again, the same issue persists.
citra_log.txt (12.3 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Go to Emulation>Configuration>Graphics>Advanced tab and disable the Disk Shader Cache here.


I don’t see the “Disk Shader Cache” available.

Ah, it’s in the Enhancements tab on 1392. I forgot we moved that to the advanced tab a while ago.


Still not seeing Disk Shader Cache

Hmm, I thought the shader cache was already implemented in Nightly 1392. My mistake then. Please upload a log file using Nightly 1392.

citra_log.txt (4.5 KB)