Citra randomly crashes with Metroid Samus Returns

Issue:
Citra is randomly crashing when playing Metroid Samus Returns. I played other games fine on this same system.

Those last lines on the log goes on indefinitely so the log becomes as big as 5mb. I had to delete a lot of these lines.

System Information

  • Operating System: Windows 10 Pro x64
  • CPU: Intel Core i3-3210 3.2GHz
  • GPU: Intel HD Graphics 2500
  • Citra Version (found in title bar): 1412
  • Game: Metroid: Samus Returns
  • Screenshot of Issue (include the full Citra window including titlebar): N/A

Diagnostic Log
citra_log.txt (25.6 KB)

System Information for Support

Client Version                                Nightly 1412 HEAD-5f20bf0
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 2500
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.10.4885
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [ ]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Nightly 1412 HEAD-5f20bf0
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 2500
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.10.4885
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [ ]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

I updated the drivers like the bot suggested and this keeps happening. So I thought I should upload a new log

citra_log.txt (360.8 KB)

System Information for Support

Client Version                                Nightly 1413 HEAD-5d502df
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 2500
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.10.5100
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [ ]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

bump

this thing happens in every game. drivers are updated

Hm, could be related to: Ocarina of Time Keeps crashing at random

1 Like

While disabling hardware shaders will make the game almost unplayable, disabling accurate multiplication may have solved my problem… or at least put it to a minimum

While it’s not a definitive solution it’s good enough for the moment. Thanks!

1 Like