Citra randomly freezes during gameplay

Issue:
Citra randomly freezes during the gameplay. The emulations goes quite good, also the framerate isn’t bad. But then, sometimes after hours of gameplay, sometimes after few minutes from the start, the emulator freezes and I have to close it with Task Manager

System Information

  • Operating System: Microsoft Windows 10 Pro
  • CPU: Intel Core i5-3320M
  • GPU: Intel HD Graphics 4000
  • Citra Version (found in title bar): Canary 1832
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (4.5 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

Thank you! I’ll wait next time the issue happens

I have now the log and the snapshot of the exactly frame where the emulator stopped citra_log.txt (1.4 MB)

System Information for Support

Client Version                                Canary 1832 HEAD-f3f2ea7
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5059
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

I downloaded the newest driver (the August 2020 version) but it still keeps the old one. Windows Update say that the drivers are all up to date.

Edit: I updated the drivers and the game still freezes.

Ah yeah, Intel HD 4000 has driver bugs so you would need to use: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392 until you upgrade your computer.

Though most people straight up crash though, but perhaps this will fix your issue as well.

citra_log.txt (182.2 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 4600
GPU Driver Version                           20.19.15.4835
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

This driver is out of date. To update, download win64_15.40.5171.zip from Intel® Graphics Driver for Windows* [15.40]
Mirror download: https://downloadmirror.intel.com/30196/a08/win64_15.40.5171.zip

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, because your iGPU has driver bugs, you’ll need to disable Accurate Multiplication in Emulation>Configuratrion>Graphics>Advanced tab to prevent graphical issues from occurring.

Additionally, you should keep your CPU Clock Speed settings at 100% (Emulation>Configuration>System). You really shouldn’t touch this setting unless you know what you’re doing.

1 Like

citra_log.txt (4.8 KB)

its keeps freezing randomly when I play some pokemon games

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

here is the log when it froze

citra_log.txt (175.9 KB)

System Information for Support

Client Version                               Nightly 1776   HEAD-6764264
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            GeForce GTX 860M/PCIe/SSE2
GPU Driver Version                           388.73
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. Official Drivers | NVIDIA
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

I’m also having the same issue, my game was running fine for more than half the game until recently. The screen freezes during fire emblem awakening.
citra_log.txt (236.9 KB)

System Information for Support

Client Version                               Nightly 1778   HEAD-a51b1cd
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz | AVX512 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) UHD Graphics
GPU Driver Version                           27.20.100.9621
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

Try disabling Hardware Shaders in
Emulation>Configuration>Graphics>Advanced Tab. See if the freezing issue remains (note that this will come at the cost of performance).