Citra refuses to run on Nvidia GPU


#1

Issue:
i’ve manually set citra to run on Nvidia GPU in Nvidia control panel but it still tryng to run in Intel HD graphics that do not support open GL 3.3, and i also have the latest driver for my nvidia card
(don’t worry about “failed to open joystick part” i have limited usb port on my laptop, and i need both my keyboard and mouse to create the log)

System Information

  • Operating System: Windows 7 64 bit
  • CPU: i5-2450m
  • GPU: Nvidia Geforce 610M
  • Citra Version (found in title bar): Citra Nightly
  • Game: MHXX

Log:

[ 0.000000] Frontend citra_qt/main.cpp:CheckForUpdates:467: Update check started
[ 62.499304] Frontend citra_qt/main.cpp:BootGame:607: Citra starting…
[ 62.616124] Input input_common/sdl/sdl.cpp:SDLJoystick:35: failed to open joystick 0
[ 62.617607] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 3.1.0 - Build 8.15.10.2538
[ 62.617689] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: Intel
[ 62.617741] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: Intel® HD Graphics Family
[ 62.617796] Render video_core/video_core.cpp:Init:34: initialization failed !
[ 62.617850] Core core/core.cpp:Load:108: Failed to initialize system (Error 9)!
.

In order to save a copy of the log, follow this guide: How to Upload the Log File


#2

There should be an option called “Run with Graphics Processor” or something along those lines when you right-click on citra-qt.exe.


#3

no difference, same result


#4

Make sure you have the latest Nvidia drivers installed for your GPU.


#5

i have the lattest driver installed, weird because i think i’m the only one with this problem


#7

The latest Canary has a PR that automatically selects the Nvidia GPU, can you test it again?


#8

i’m using nightly, is that different? because it’s automatically downloaded from the website, where i can download the canary ver?


#9

You can select to install Canary on the same installer.


#10

hey, right click your desktop and go to nvidia control panel, then on the left manage 3D settings. After that on the right click the tab that says program settings. Click add button, and locate the citra-qt.exe and click add selected program. Should see something down below that says Open GL rendering GPU with a drop down box beside it. Select your nvidia gpu and click apply. Maybe that will solve your problem


#11

Wow, I have the same problem. I thought that manually selecting Nvidia was solving the problem, but turns out that I’m still using the Intel then!

Anyway, Samuel_Grooms’ solution didn’t solve the issue :confused:


#12

Have to use a rubbish Nvidia GeForce 9500 gt because the intel hd graphics (2000) don’t support opengl 3.3 and my one works with this emulator