Citra running too slow

Issue:
I found that the Citra is running slow, it just like about 40% of speed and 20-30 fps, is there any way to improve it? Thank you!

citra_log.txt (352.5 KB)

System Information for Support

Client Version                                Canary 1831 HEAD-d0ec7c0
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            26.20.100.7870
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: Build 26.20.100.7870

This driver is outdated, you need to update.

Download igfx_win10_100.8587.exe from https://downloadcenter.intel.com/download/29808/Intel-Graphics-Windows-10-DCH-Drivers?product=195436
direct link: https://downloadmirror.intel.com/29808/a08/igfx_win10_100.8587.exe

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Make sure you are using a high performance power plan in Windows and be plugged in.

Try a different game, maybe that Ace Attorney game isn’t optimized.

Thank you for your prompt response😀
I would like to know do I need to delete the opengl file everytime before running the game?
And is it a must to have the laptop be plugged in?

No, you do not have to delete it every time. If you enable Accurate Multiplication it will prevent the bug in the future. You just have to delete it once so it can be built up from scratch correctly.

You get more power when you are plugged in, which should enable you to get more performance.

Thank you so much for the suggestions!!
It runs better and faster than before👍🏻

1 Like