Citra runs Pokemon UltraSun at very less Framerate after Update

Pokemon Ultra Sun runs extremely slow, very less Framerate
Which makes the game almost unplayable as it takes a lot of time
Also I have Accurate Multiplication under Configure->Graphics->Advanced enabled

System Information

  • Operating System: Microsoft Windows 10 Home (10.0.18362 Build 18362)
  • CPU: Intel(R) Core™ i9750H CPU @ 2.60GHz
  • GPU: Inter(R) UHD Graphics 630 and NVIDIA GeoForce GTX 1650
  • Citra Version (found in title bar): Citra Nightly 1535
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide: (54.9 KB)

System Information for Support

Client Version                                Nightly 1535 HEAD-41bff0e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) UHD Graphics 630
OpenGL Version                                3.3.0
GPU Driver Version                  
Enable CPU JIT                                [x]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Show status bar with CTRL+S or View->Show Status Bar, need to see the numbers :stuck_out_tongue:

If Citra is using your iGPU and not your GTX 1650 then open Nvidia Control Panel then in “Manage 3D settings” set preferred GPU to Nvidia. While you are there also set Power management mode to Prefer maximum performance or at least Adaptive.

If you have GeForce Experience installed you may need to do this as well:

1 Like

I changed default 3d settings to GTX 1650 one, and it just works fine Thank You…! :star_struck::hugs:

Just 1 more question, considering that I changed to the powerful Nvidia just now, how was my iGPU able to run the game with a good framerate before the update(though at some instances it would slow down a lot, but it was good enough)

We would need to bisect to find out. Do you remember what build was fine on the iGPU?

It was a Nightly 1523 build I think :sweat_smile:

Hm, cannot see anything obvious between latest and 1523 that would cause slowdowns. But you probably won’t go back to using the iGPU :stuck_out_tongue:

1 Like

Yea it’s way better now, thanks for helping out :grin:
Such a Great community with Greater people

1 Like