Citra save states + files

On 4/10, I tried changing the system clock in settings to be met with all my save data for tomodachi life wiped. I stopped playing for around 9 days, and found that I had a backup save. (Will be marked as (B)) I don’t care about the save data, since I have the save state, but whenever I try to save in game I see a corrupt data message. I tried making a new save slot (A) to attempt to save on the other save data (B). Yet it didn’t work, since it keeps going back to save (A). When I check the save data file, it seems to be the same version of save file B but corrupted? I could be wrong, but it seems that way. I can explain more, but this is very confusing.

citra_log.txt (1.6 MB)

Save states save the entirety of Citra’s emulation state, and as a result, new Citra updates that add new things to serialize in the emulation state will break the loading of save states that were created on prior Citra versions. Additionally, saving upon save state created progress will make the emulation state gradually more unstable. Since the emulation state never gets to clear out emulation bugs with a proper shut down. This is why in-game save files should be used most of all when saving and loading your progress. Save states should only be used within single gaming sessions, not beyond them.

As such, it’s very likely that your current emulation state has become too unstable for regular saves to be performed. Another thing that supports that is your emulation state’s insistence on trying to use the old location for nand data.

Your custom set location for nand:

[   3.369390] Config <Info> common/settings.cpp:operator():111: DataStorage_NandDir: M:/3ds/videos & images/

What location your emulation state thinks it should be using, but obviously fails to do so:

[ 827.242267] Service.FS <Critical> core/file_sys/savedata_archive.cpp:OpenFile:91: (unreachable) Unknown error opening C:\Users\AJ\AppData\Roaming/Citra/nand/data/00000000000000000000000000000000/sysdata/00010026/00000000/CEC/0008c500/InBox___/BoxInfo_____

This suggests that, at first, you saved your first save state before you changed the location of the nand folder in the settings. So the save state saved the old file path and continues to try and use that, but fails. The sdmc folder, which you’ve changed to the same location as the nand folder, holds your normal save data location. I assume that that is having a similar issue.

Essentially, you’ve broken Citra’s virtual file system. You can try disabling the custom locations for nand and sdmc and then save in-game again. But I’d honestly be surprised if that would work at this point.

I disabled the custom locations like you said, and it worked! Thank you so much, I would definitely not know what to do, you saved so much of my data.

1 Like

That’s a very unexpected surprise, but certainly not an unwelcome one! I suggested it just in case, but I really did not expect it would work. Not that I’m complaining :smile: