Citra settings on steam deck Windows?

Issue:
Windows Citra on steam deck has been unplayable for me… It worked great in Linux but I switched over to windows completely.
specifically trying to play Zelda, Link Between worlds with default settings(also fiddled with no change) and I can barely get past the loading screen it runs so slow. Again, ran great in Linux. am I doing something wrong?

System Information
Steam Deck
citra_log.txt (12.4 KB)

AMD APU

  • Operating System: Windows 10 Pro
  • CPU: Zen 2 4c/8t, 2.4-3.5GHz (up to 448 GFlops FP32)
  • GPU: 8 RDNA 2 CUs, 1.0-1.6GHz (up to 1.6 TFlops FP32)
  • Citra Version Citra Nightly
  • Game: The Legend of Zelda: A Link Between Worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I also uploaded the photo, not much to see but it loads up extremely slow and is almost unplayable

System Information for Support

Client Version                               Nightly 1794   HEAD-e24e2a8
Operating System                             Windows 10 Version 2009
CPU                                          AMD Custom APU 0405 | AVX2 | FMA
Graphics API                                 OpenGL 4.3.1
Graphics Renderer                            AMD Custom GPU 0405
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Please enable the Vsync option if you are experiencing screen tearing.

No, you’re not doing anything wrong. I welcome you to proprietary AMD Windows OpenGL drivers! Welcome to hell!

In all seriousness, Linux has way better open source OpenGL drivers, which is why performance was so vastly better on that end. AMD has actually recently updated their OpenGL drivers, making them actually decent on Windows. however, those are currently still optional drivers. This means that in order to benefit from them, you’d have to manually install them.
Usually, that isn’t an issue, I would just link it to the user and everyone would be happy, however I have no idea where to find the drivers for the Steam Deck’s GPU. At least, I wasn’t able to find them on AMD’s site.

If they cannot be installed yet, you’ll need to wait until the OpenGL changes make their way into the recommended drivers, though I don’t know how long that’ll be.
Until then, try disabling Hardware Shaders in Emulation>Configuration>Graphics>Advanced tab. That used to sometimes improve things for AMD GPU users on Windows.

1 Like

sigh… well thanks for the info and for taking a look! I guess I’ll just wait to see if any one knows where to find drivers. I didn’t know it would be so much different to run Citra on windows. I am a noob with emulators and am only just hearing about Open GL.

But also going to try what you said with the shaders option. Thanks!

It drastically improved after disabling the hardware shaders!! Thanks a ton! Not sure of what that setting is :man_shrugging:t2:, but it got better now!

1 Like