Citra slow on my laptop

Issue:
Enter a description of your issue here, in full detail.
it’s inconsistent fps is annoying, hovering between 20-30 fps with frequent slowdowns, im plugged in, used the lowest resolution and have the slider to best performance, i have the latest drivers still no go.

System Information

  • Operating System: Windows 10
  • CPU: Intel i5-8250u
  • GPU: Radeon 530/ UHD 620 dual graphics
  • Citra Version (found in title bar): Citra Nightly 1548
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (4.3 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first, then start the game and when you close Citra, immediately upload a new log here.

sorry here it is
citra_log.txt (48.6 KB)

System Information for Support

Client Version                                Nightly 1548 HEAD-51dfc46
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) 530
GPU Driver Version                            20.4.2 26.20.15029.27016
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Yeah you can try run on the iGPU instead of Radeon. To do that you need to configure Switchable Graphics in Radeon Settings: https://www.amd.com/en/support/kb/faq/dh-017
As you can read in the article:
Power Saving - Selects the integrated GPU, which consumes less power but provides lower performance”
however it might run better for Citra. Upload a new log with the iGPU so we can check its driver version, latest is 8190.