Citra slow until settings changed (SMT IV:A)

Issue:
After loading a file or sometimes when entering a new area, the game starts running at 75-90% speed. However, after changing the resolution from 2x to 1x it goes back to 100%, and stays at 100% even after returning to 2x resolution. The same thing occurs when changing the texture filter to or from any option.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4440
  • GPU: Intel HD
  • Citra Version (found in title bar): Nightly 1717
  • Game: Shin Megami Tensei IV: Apocalypse

Diagnostic Log
citra_log.txt (226.9 KB)

System Information for Support

Client Version                                Nightly 1717 HEAD-647a6f8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            20.19.15.4531
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

^ This driver is out of date, to update, download win64_15.40.5171.zip (direct link) from Download Intel® Graphics Driver for Windows* [15.40]

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, enable Shader JIT in Emulation>Configuration>Graphics>Advanced Tab.

If that doens’t fix the issue, also try disabling your texture filter, then restart your game. Let us know if this solves the problem.