Citra slows down after few seconds in Fedora

Issue:
Enter a description of your issue here, in full detail.
So, i installed Fedora on my system today, compiled it with the release parameter in Cmake (and also downloaded the official version, it is the same), but noticed it runs much slower than in windows, but only after few seconds. In linux it runs around 70-80%, but in windows it runs 96-100% (cheats are no outlines, but it is the same). And this has been happening to me for the past year, so i had to be dual-booting with Windows. It slows down even if i am just standing. (Screenshots right after opening a game and after standing or walking for a few seconds, it is not just fhe FPS count, i can feel it getting slower).

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               master-bf6e4a41d
Operating System                             Fedora Linux 36 (Workstation Edition)
CPU                                          Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.6
Graphics Renderer                            Mesa Intel(R) UHD Graphics 620 (KBL GT2)
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

System Information for Support

Client Version                               master-bf6e4a41d
Operating System                             Fedora Linux 36 (Workstation Edition)
CPU                                          Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.6
Graphics Renderer                            Mesa Intel(R) UHD Graphics 620 (KBL GT2)
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Does the same thing occur when installing Citra through flathub?