Citra slows down and speeds up randomly

Issue:
Sometimes it’ll run games with 10x native resolution without any problems at all, other times it stuggles to run games with native resolution. I don’t know if this has to do anything with my laptop’s operating mode (power plan/profile, whatever you call it), but probably not.

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel Core i7 9750H
  • GPU: NVIDIA Geforce GTX 1650
  • Citra Version (found in title bar): Citra Canary 1825
  • Game: Pokémon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (50.9 KB)

System Information for Support

Client Version                                Canary 1825 HEAD-e1eca22
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 630
GPU Driver Version                            26.20.100.6911
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Go into Nvidia Control Panel and in Manage 3D settings, set Preferred GPU to Nvidia.

While you are there, set Power management mode to Prefer maximum performance. If you have GeForce Experience installed, turn off Battery Boost:

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and turn on Hardware Shader

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.
Keep Accurate Multiplication enabled.

10x resolution is overkill if you don’t have a 4K screen(9x is 2160p which would be preferred 4K resolution).

If you are on a 1080p display then 4x is enough with Large Layout because then the top screen is exactly 4x, beyond that you will see diminishing returns(can’t really see a difference above it).

I think maybe you pressed the “+” by coincidence,because it can speed up your game.
Try pressing “-” to slow it down:)