Citra Slows Down

Issue:
Well. I had this issue last year too. it solved itself after formatting my laptop, Every Game Slows Down After Some time. I Used Resolution at 4x with speeds ranging from 120%-200%.
System Information

  • Windows 11 Pro 64-bit
  • AMD Ryzen 5 Mobile 3500U:
  • Picasso 12nm Technology:
  • Citra Version (found in title bar):
    Nightly 1827
  • Game:
    Doesn’t depend on the game, Though The One that is mostly affected is miitopia

Diagnostic Log
Game Doesn’t Crash. Still It Has Speeds Ranging from 40%-60% with lowest settings

1 Like

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

We need a log in order to help you. It will tell what settings you use and what driver version you have.

the game doesn’t crash. it won’t create a log if it doesn’t crash

Citra always creates a log when you exit the app.

oh, i didn’t know those logs, ¿where do i find them?

Emulation → Configure → General → Debug to access your log file.

citra_log.txt (53.8 KB)
done, is this it?

Yup, thanks.

Core_CPUClockPercentage: 150

This should be set to 100% otherwise the emulator will be unstable.
If you are using save states, make sure after you load that you set it to 100% and then save a new state. Load state also changes Citra settings.

GL_VERSION: 4.3.13596 Core Profile Forward-Compatible Context 20.10.36 27.20.11036.3

Latest drivers are 22.11.2, it also includes OpenGL optimizations. Get them here: https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-5-mobile-processors-radeon-vega-graphics/amd-ryzen-5-1

it didn’t work…well, ¿what else can i do?

Upload a new log please.

sure,
citra_log.txt.old.txt (2.3 MB)
here is a new one, I don’t know which one is needed
citra_log.txt (5.8 KB)

Drivers are still not updated, check the AMD link above.

CPU clock is still not 100%, you have it at 105% right now.

Turn on Hardware Shader (it will be faster after you’ve updated the drivers).

Turn off Dump Textures(you should delete the dump folder as you probably have a lot of textures in there now. You can access it from File->Open Citra Folder).

1 Like

the updated drivers made it worse, but later it was faster…
I Tinkered a bit and with a 5% overclock its faster than 100%
i also turned hardware shader off (it made my games faster)
after i turned off dump textures and deleted the folder… hooray! it’s all back to normal, thanks!, also i had almost a gigabyte of dumped textures. thanks again ^^

Upload a new log and we can double check if your drivers are truly updated to latest Adrenalin 22.11.2

The new drivers have OpenGL optimizations which will make Hardware Shader faster for you.

105% CPU clock will make emulation unstable, so if you randomly crash or freeze then you will know what you need to change.

Sure
citra_log.txt (113.4 KB)

Texture Dumping is back on, are you loading save states? Like I mentioned before, states also load Citra settings so if texture dumping is turned on in the state it will be back on even if you turned it off before starting the game.

The default shortcut is CTRL+D to turn on/off Texture Dumping so don’t press that combination.

GL_VERSION: 4.3.13596 Core Profile Forward-Compatible Context 20.10.36 27.20.11036.3

Still old drivers. If you Google 20.10.36 27.20.11036.3 you will find it’s at least 10 months old:
image

22.11.2 is just over a month old.

If you didn’t see the link, here it is again: https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-5-mobile-processors-radeon-vega-graphics/amd-ryzen-5-1

So make sure you run whql-amd-software-adrenalin-edition-22.11.2-win10-win11-dec8.exe after you download it :slight_smile:

I did install it
image
i also turned off texture dumping for miitopia, i’ll check again

Ok, fair enough. Hopefully it says 22.11.2 in Radeon Software, like this:

1 Like

Actually… I just realized I didn’t get Adrenalin app
well, still got my issue solved, I can also say. I deleted all the contents of the dump folder
but I think that’s external to Citra…
¡Thanks for helping me! ^^

1 Like